recgroups : web-based newsreader


We've detected that you are using an out-dated
or unsupported
version of Netscape.

The minimum version of Netscape we support is 7.2.

(You are currently using version 5.0 )



In order to provide the best experience possible to the majority of our visitors, recgroups utilizes many advanced features that are only available on the latest generations of web browser software. We highly recommend that you upgrade your software.

Only the latest versions of the following browsers are currently supported.
Click an icon to open the download page.

Windows:   MacOS:   Linux:

firefox
Firefox

(0.9+)

internet explorer
MSIE

(6+)

netscape
Netscape
(7.2+)
 
firefox
Firefox

(0.9+)

safari
Safari

(1.2+)
 
firefox
Firefox

(0.9+)

netscape
Netscape

(7.2+)

You can "continue" to recgroups with your current browser, but we do not guarantee
that it will function properly, if at all. You've been warned!


continue...